On my fourth pain pump

New Topic Post Reply Printable Version
[ << Previous Thread | Next Thread >> ]

Pebbles Mom
New Member


Date Joined Dec 2017
Total Posts : 1
   Posted 12/31/2017 11:22 PM (GMT -6)   
Hi, this is a long story so I will try and simplify. June 2016, I had my first pain pump installed. Even before I had my staples out I had HORRENDOUS fall which basically pulled the pain pump out from the muscle wall and twisted the cord so badly that the pain pump stopped working. We found all this out while trying to refill the pump and found it upside down. Went in for surgery the next day for a new one. all is well, had almost complete pain relief!! I had my life back. Truly did! Month or so later, another fall. turned around quickly lost my balance and sat down hard on table. Guess what Tore it out again. So this time they took it out and put it into my left side. Well guess what? I developed a staff infection in it. So from Feb 14th to March 23, I endured rounds of antibiotics and a stomach that looked like I had a ten pound bowling ball in it. But, the pump was working and I had complete relief. So they had to take it out, spent 4 days in the hospital on super antibiotics. They told me I had to wait at least six weeks before I could have the pump put back in. So they took it out and immediately that nagging awful every minute of my life pain returns. So seven weeks past and in June of 17 I went in for surgery of the new pump. The second I opened my eyes, I said wait, the pump is not working, they couldn't do it! My pain is still there! But no, they told me it was in and working fine. Want a bet? We did a die test showing the dye going in. Why in my first 3 did I get 90-100% relief and nothing, I mean nothing out of this one! Tuesday I in for surgery for a spinal stimulator. I can't take the back pain anymore and am ready to check out. Anybody got any ideas

straydog
Forum Moderator


Date Joined Feb 2003
Total Posts : 16789
   Posted 1/1/2018 9:01 AM (GMT -6)   
Hello Pebbles Mom & welcome to the forum. What an incredible journey you have been on with pain pumps. I can't answer why the 4th pump did not work. If the catheter was not kinked, no cracks & the unit checked out fine according to the computer check, I just do not know. Did they have medication in the pump or saline? That would be my only thought.

I am guessing you have already done the trial for SCS unit. I do hope you get relief with the unit. Keep us posted on how you are doing. Take care.
Susie
Moderator in Chronic Pain & Psoriasis Forums
New Topic Post Reply Printable Version
Forum Information
Currently it is Saturday, September 22, 2018 3:34 PM (GMT -6)
There are a total of 3,005,717 posts in 329,256 threads.
View Active Threads


Who's Online
This forum has 161799 registered members. Please welcome our newest member, Meghana.
275 Guest(s), 9 Registered Member(s) are currently online.  Details
ezhoe, BangedUp, Kent M., Vdang2k, Louiseluck, Splashdancer, Alxander, Traveler, scorpio-girl