Severely stressed by protein in urine, no casts.

New Topic Post Reply Printable Version
[ << Previous Thread | Next Thread >> ]

Flyers13
New Member


Date Joined Feb 2016
Total Posts : 1
   Posted 2/21/2016 6:35 PM (GMT -7)   
Hello! I'm hoping that someone can help to alleviate my severe stress level. For my annual checkup a week ago, I had a urinalysis done. This is the first time I've had this done, as I have a new doctor. The results showed that I was a 1+ for protein. Specific gravity was 1.015 and everything else was negative. There were no red blood cells, no white blood cells, no epithelial cells, no bacteria, no crystals, and most importantly no casts. The one very strange thing was a PH of 8.5, which seems way out of wack. I took my PH here at home, and it's around 6.0. I have read that a high PH can cause a false positive for the protein. So, my doctor said that he wanted me to come in to have it checked again. In the meantime, like an idiot, I went searching around on the internet about chronic kidney disease. So, I was freaking out for almost a day, and gave my second test the next morning. However, when I urinated in the morning, the water in the toilet foamed up like a mug root beer! Then I REALLY started freaking out, reading that foamy urine means protein in the urine. I do NOT remember seeing foam in my urine before this. I do have a long history of anxiety and panic issues. I do NOT have a history of chronic hypertension. If I'm at the doctor's office, or times when I'm anxious and panicky, my blood pressure can get above 140/90. Most of the time it is below 130/90, and I can get it to 120/80 or lower when I'm completely relaxed. My prior doctor almost always told me 120/80 when I was in for checkups. Also, back in November I had blood work done, and that showed that my creatinine level was on the high side of normal (1.19), but still in normal range, and I have no idea if I exercised the night before, ate meat, etc. More importantly, my blood albumin level was right in the middle of normal at 4.4, and total protein was also in normal range, and my BUN was 15. I have read that stress can cause there to be protein in the urine, and I'm REALLY hoping that is what is causing what I'm seeing, because everything else seems to look good in the tests, especially that there were no casts found. One further thing...there was ONE time since I had the second test that I had a long stream of urine, and there was NO foam in the water...completely clear. This was after I had spent some time with a friend and was fairly calm. However, every time since then...the last 2 days...foam every time. I'm to the point where I'm not even looking...just turning my head away. I'm hoping that someone else has had a similar experience and can tell me that there is a chance the foam can be caused by my stress level, and that I just need to calm down and relax since all the other tests look good. I have some hope because of no casts being found, and because of the prior blood work and the one time I urinated with no foam. If someone has something to say that will just further stress me out, then PLEASE do not post! Today is Sunday, so I won't have access to my doctor until tomorrow, so anything positive that I can see or hear today would be greatly appreciated. Thanks!
New Topic Post Reply Printable Version
Forum Information
Currently it is Monday, December 18, 2017 3:32 AM (GMT -7)
There are a total of 2,906,667 posts in 318,985 threads.
View Active Threads


Who's Online
This forum has 158324 registered members. Please welcome our newest member, 465456.
225 Guest(s), 3 Registered Member(s) are currently online.  Details
Dimitri71, CassandraLee, testuser1234