Blood in Urine

New Topic Post Reply Printable Version
[ << Previous Thread | Next Thread >> ]

sm416
Regular Member


Date Joined Sep 2010
Total Posts : 27
   Posted 9/15/2010 5:57 AM (GMT -6)   
Hello all,
 
Any one ever experience blood in the urine 5 weeks out from surgery?  I noticed today that I have droplets that are pink in color.  I went to to doctor last Friday and he indicated that the flow and discomfort may be from urethral strinture and felt that we may do more damage for what has been healed by taking a look with a scope.  Any feed back will help.
 
Thanks
 
Steve
Age: 58 Married 28 Years.
Initial PSA 2.9 elevated to 5.7 before Robotic RP surgery
33% of 1 of 12 biopsy points (left side near bladder)
August 9th Prostectomy with 3D Robotic Surgery
August 16 Staples and cath removed

Paul1959
Veteran Member


Date Joined Nov 2007
Total Posts : 598
   Posted 9/15/2010 6:16 AM (GMT -6)   
Steve,
Very common to have blood even 8 weeks out of surgery. This should be in material your doc sent home with you. The only time to worry is when you can't pee. Otherwise, blood, clots and creepy stuff are normal. What looks like a lot of blood is often just a tiny capillary whose scab has come off.  At this date it is scabs falling off, or perhaps you over did it the day before? many different causes, none are of major concern.
Paul

sm416
Regular Member


Date Joined Sep 2010
Total Posts : 27
   Posted 9/15/2010 6:58 AM (GMT -6)   
Thanks Paul,

I noticed just awhile ago dark colored material was discharged. The information about the clots was also helpful, since that is what was in the discharge.

Steve
Age: 58 Married 28 Years.
Initial PSA 2.9 elevated to 5.7 before Robotic RP surgery
33% of 1 of 12 biopsy points (left side near bladder)
August 9th Prostectomy with 3D Robotic Surgery
August 16 Staples and cath removed

NEIrish
Regular Member


Date Joined Aug 2010
Total Posts : 245
   Posted 9/15/2010 8:51 AM (GMT -6)   
sm416 - The timing was exactly the same for my husband - no blood after the cath had been removed for a few days, then some showing up 5 wks. later. A call to the doc's office rec'd the same info Paul just gave you. Sounds like you're healing, since the clots are shedding...
Husband 60yrs., no symptms: PSA 10/04 2.73, 12/06 3.64, 5/09 3.9, 10/09 4.6, 1/10 5.0w/ free PSA 24
6 core biop 4/1/10 path rept: rt mid: adnocarc. G=3+3, 5% of core; R apx v. susp. minute ca, R base bnign w/ mod. atrophy, L side atrphy only; 2nd opnion JH confrmd
MRI - 15mm nodule
BiLatRP surg 7/6/10, path: T2c, nodes, sem.ves, extra caps. neg., adenoc both sides G=3+3 cntinent, Viagr-8/27 ED
New Topic Post Reply Printable Version
Forum Information
Currently it is Thursday, September 20, 2018 9:49 PM (GMT -6)
There are a total of 3,005,308 posts in 329,211 threads.
View Active Threads


Who's Online
This forum has 161767 registered members. Please welcome our newest member, Titanium-Girl.
330 Guest(s), 8 Registered Member(s) are currently online.  Details
Chask, PeterDisAbelard., xpeetzax, Girlie, delta30, WalkingbyFaith, commandersorebod, mufjem