my first Sigmoidoscopy

New Topic Post Reply Printable Version
[ << Previous Thread | Next Thread >> ]

saposs
Regular Member


Date Joined Nov 2008
Total Posts : 339
   Posted 1/20/2009 3:12 PM (GMT -6)   
I finally had my Sigmoidoscopy last week and now waiting for the results of biopsy taken. On the screen, the examination showed area in the beginning which has turned red (dnt know how to explain it)..... the lining was red and there were patches which were bleeding and had mucus (this was something more than just hemorrhoids that my GI had initially thought) ... :-( so biopsy have been taken... further up it was fine. Since the Sigmoidoscopy was done, i m having pain while passing stools! and mucus/blood has increased a little.
M scared about the results, lately all the test results i m getting are upsetting- i tested positive of thyroid antibodies(immune disease) ... those antibodies are killing my thyroid glands :-(
Mucus & Blood in stools, Gas, Constipation sometimes - No D !
Guessing i have IBD, first doctor visit scheduled mid-December'08.
On no medication.

Post Edited (saposs) : 1/20/2009 2:14:56 PM (GMT-7)

New Topic Post Reply Printable Version
Forum Information
Currently it is Tuesday, September 18, 2018 11:50 PM (GMT -6)
There are a total of 3,004,514 posts in 329,151 threads.
View Active Threads


Who's Online
This forum has 161742 registered members. Please welcome our newest member, Belcorgin.
232 Guest(s), 5 Registered Member(s) are currently online.  Details
ezhoe, dbrookenz, Darwayne, John T, Lightlife